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1 Helmsman’s Display 4 

The Helmsman’s Display 4 is a completely new solution and brings online navigation in a 

3D environment. It opens new possibilities for handling larger amounts of data, support of 

new formats, native 3D providing optimal 3D performance, full Windows 10 integration, 

tailored display layout, tracking of multiple 3D objects the same time, possibility for using 

online background maps and much more. 

Helmsman’s Display is developed to meet the needs of an industry in constant change. 

Together with feedback from all our valued customers we will continue to develop this 

product to the ever-changing requirements of the market. 

This approach brings several additional functionalities: 

• Bathymetric surveys with live DTM from multibeam  

• Live laser point cloud data 

• 3D structures and vessels 

• Cable and anchor installations 

• ROV support 

• Towed side-scan sonars and vehicles 
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2 What is new? 

2.1 Templates  

The use of several templates based on work scope allows the user to define the desired 

layout and save it. You can have multiple layouts (e.g. one for MBES/LiDAR survey, one for 

ROV operations, one for eventing in case you have a separate operator or one for QC-ing). 

You can define screen layouts and save them as a named template. A template will include 

information on which windows, data sources, view settings, dockings, window sizes and 

placements are saved. 

 

Figure 1 Where to find the Window-layout options 
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By default, the saving and loading of the templates will be done in the folder 

C:\ProgramData\EIVA\Helmsman\Layout.  

2.2 Connection  

Connecting and getting data from NaviPac and NaviScan is simple. You should click on 

connect and it will provide you with a list of NaviPac and SceneServers online on your 

network as well as any defined external network servers. 

The selected connection will be saved with your project and re-established on start-up. 

There is an icon showing you if there is any issue with your connection to the NaviPac 

server. 

 

Figure 2 How to connect to a server and where to find the Status icons 
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2.3 Maps and drawings  

Helmsman’s Display supports a wide range of online map servers and formats. It allows for 

multiple 3D views simultaneously, unlimited data size, map tile servers and navigation 

charts providers, AutoCAD, S-57 and MicroStation 2D drawings. 

The background Maps can be added by using the Select Background Map from the View 

Toolbar.  

Maps can be downloaded on shore and used offline if the survey area does not have good 

internet connectivity by following this procedure. 

 

Figure 3 Background Maps - button location and standard map servers 

  

https://eiva.freshdesk.com/a/solutions/articles/43000598028
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2.4 Data Views, Dashboards and Graphs 

The Helmsman’s Display 4 is also coming with an upgrade of how a user can monitor and 

present live data. 

The user can define which real time items are shown and have a good control on what data 

to display, rename label, control sizes independently, show/hide columns and control 

logging/view time. The data can come from sensors or processed through DataMon. 

Mathematical functions can also be used to calculate values in the live display. This is 

presented in more detail in chapter 4.3 Graph Views, 4.4 Dashboards and 4.5 Data View. 

 

Figure 4 Graph View 

 

Figure 5 Data view and Dashboard 
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2.5 Auto-follow 

The auto-follow functionality allows for several ways of focusing on or tracking objects. 

These are: 

• Select object to Follow 

• North Up Follow Mode 

• Runline Up Follow Mode 

• Gyro Up Follow Mode 

• CMG Up Follow Mode 

• Decide view angle or look forward 

• Keep object in the center of the screen (but do not shift the map before it leaves the 
defined area) 

 
Figure 6 The Follow toolbar and follow options 

2.6 Live 3D data 

The collected data can be viewed in real time if you are connecting the Helmsman’s Display 

to NaviScan. This can be done using the same procedure as described in chapter 2.2 

Connection for NaviPac and/or NaviScan. 

Online DTMs can be filtered in real time using EIVA’s EC-3D tools. 
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This will allow you to view and control: 

• Raw point cloud data (MBE, LiDAR, laser) 

• Real-time DTM 

• Generate coverage on top of maps or previous surveys 

 

Figure 7 Real time DTM and point cloud during ROV-mounted dual head MBES survey 

2.7 NaviModel features 

Being based on NaviModel, the Helmsman’s Display also brings with it the following 

additional features: 

• Difference Models 

• Gap Analysis 

• Trench / rock dump design 

• Digitized lines 

• Cross Profiles 

• Live profiles between moving objects 

• Volume Calculations 

• Measurement 

• Full online Eventing package 

• Video file playback 
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3 Menu Bar 

The Menu bar is located on the upper left corner of the display.  

3.1 File 

 

Figure 8 The File menu 

The File menu contains the following sub-menus: 

• New - Create a new Helmsman’s Display project 

• Open Project - Open an already existing project 

• Add File(s) to Project - Allows for adding files; new files can be also added by drag 
and drop 

• Save - Save recent changes in the project 

• Save Project As… - save as a new Project 

• Auto Save Project… - allows the setting up of a time interval at which the changes 
will be automatically saved 

• Recent Projects – easy selection of recent opened Projects (ordered 
chronologically from recent to old) 

• Recent Folders – shows a list of folders where projects and files have been saved 
(ordered chronologically from recent to old) 

• Recent Files – allows for quick access to previous saved files or projects  
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3.2 View 

 

Figure 9 The View Menu 

The View menu contains the following sub-menus: 

• New Map View – opens a new Map View. The new Map View can be used to 
display the site from another perspective (e.g. an overview map or a detailed view 
of an ROV survey) 

• New Graph View – allows for the setting of a Graph View 

• New Bulls eye View – opens a Bulls eye View 

• New Browser – opens a web browser in Helmsman’s Display 

• New Dashboard – opens a New Dashboard. You can choose what elements to be 
displayed 

• New Data View – opens a new numerical Data View with both a graph and 
numerical value. The columns can be adjusted 

• New Left/Right Indicator – opens a new view which shows the user information 
about the location of one vehicle compared to a line, e.g. vessel following a runline. 

• New Cross Profile – opens a new Cross Profile. 
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• New Waypoint profile – opens a new waypoint profile view. It shows a dynamic 
view between the selected vehicles on the X axis and depth on the Y axis. 

• New NaviScan profile – opens a NaviScan profile 

• New Range and Bearing View - opens a new range and bearing view between 
user selected objects. The user can also choose to see the dX, dY, dZ and 2D and 
3D ranges 

• Vehicle Control – opens the Vehicle Control view. This is similar to the old Runline 
Control in previous version 

• Views – opens a list of views the user can have visible in the HMD 4 project 

 
Figure 10 The Views sub-menu 

• Toolbars – the user can select here which toolbars should be displayed 

 
Figure 11 The Toolbars list 
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• Window-layout – provides the options for using window layouts. You can save the 
current lay-out, load a user defined template or manage the startup layout (see 
chapter 2.1 Templates) 

 

Figure 12 The Layout options 

3.3 Settings 

 

Figure 13 The Settings menu 

The Settings menu contains the following sub-menus: 

• Geodesy and Datum Shift – are greyed out as they are taken directly from 
NaviPac 
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• Project Settings – here you can set up the units (e.g. metric or imperial system) 

 

Figure 14 The Project Settings window 
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• Program Resolution – opens a window where the user can adjust the video 
resolution 

 
Figure 15 The Program Resolution window 

• Workspace – opens a window where you can select a workspace 
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• Options – opens a window where the user can adjust general visual, runline, online 
eventing and shortcuts settings 

 

Figure 16 The Options window 
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3.4 Tools 

 

Figure 17 The Tools menu 

The View menu contains the following sub-menus: 

• Cleaning – limited to Histogram Plane and Spike filters (for more advanced 
cleaning options the user needs to use NaviModel) 

• DTM – from here the user can create difference models choose palettes, opacity 
and fill DTM secondary cells 

• Eventing – options for creating and QC-ing Event Collections, freespan and burial 
events  

• Follow – provides a submenu with options for following vehicles and objects, like 
the Follow Toolbar 

• Lines – here the user can create new digitized lines, runlines, waypoints and 
enable the Vehicle Control  

• Live Data – opens a sub-menu where the user can set up custom live data views, 
live distance between objects or to DTM, volume differences, depth of burial or KP 

• Live Point Clouds – allows the user to set up a new live point cloud in the project. 
It requires XYZ incoming data from NaviScan and can be used as a live QC tool of 
MBE and LiDAR data. 

• Maps – allows for the choosing of different items to be presented in the map view or 
adjust settings  

• Measurements – the user can select to measure or toggle on/off profiles 

• Misc – allows the user to set up the Virtual Buoy Manager, Node Sorter, Live Folder 
and the Side Scan Sonar Classifier tool 

• Patch Test – opens the Patch Test tool where the user can calibrate for the latency, 
roll, pitch and heading differences between the IMU and position and MBE head 

• Point Clouds – opens a sub-menu with tools for the management and processing 
of point clouds 
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• Video-recording – allows the user to record video and take screenshots 

3.5 Help 

 
Figure 18 The Help menu 

The Help menu contains the following sub-menus: 

• Graphics – this will open a window that will run a diagnostic of your graphic card 
driver (OpenGL) and which version is recommended for use with the current version 
of Helmsman’s Display 

• Show us a Problem – will open the Step Recorder tool in Windows and will 
generate a screen-by-screen view of all interactions. The tool is intended for bug 
recording and should be sent to the EIVA Support team for investigation. 

• Support – a link to EIVA Support webpage where you can find the contact details 

• Download site – a link to EIVA download site, where you can find the latest 
installers 

• Training – a link to EIVA Training webpage where you can check the schedule for 
future training courses 

• eLearning – a link to EIVA eLearning webpage 

• Search for Help – will automatically search on our website based on a chosen 
keyword / phrase 

• License Info – will open a window where the user can check information regarding 
his dongle and PC Code 

• License Activator – will open the License Activator window, where the user can 
use an activation key to set up his license. The license is required by NaviPac to run 
on the main navigation PC. Helmsman’s Display can be used as a standalone 
program without a license in Line Planning and Remote distribution modes 

• About – will open a window with information regarding the Helmsman and NaviPac 
version 
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4 Views 

The Views in Helmsman’s Display 4 consists of a large choice of dynamic and user 

definable views. 

The user can choose to have the Views docked or floating and combine them with 

statistical and graph data and profiles. 

Docking a view can be done by dragging the view until the icon of a rectangle with an arrow 

in from appears. 

 

Figure 19 Dock View 

The Helmsman’s Display can be run in both 2D and 3D mode. 

4.1 General Views 

There are several views in Helmsman’s Display which are common in any setup. The two 

most common are the Project Tree and Properties. 

The Project Tree contains all used items, connections, pallets, views and data. The top line 

is the name of the project.  
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By selecting an item in the Project Tree, the user can adjust its settings in the Properties 

view. 

 

Figure 20 Project Tree and properties for a DTM 
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In the upper right corner, the user has the option to close the View or auto-hide to allow for 

the display of a larger Map View for example. 

Other common Views are: 

• Job List 

• Log Window 

 

Figure 21 Log Window 

• Undo/Redo History 

 
Figure 22 Undo/Redo History 

• Profiles 
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4.2 Map Views 

The Map View is used to display the vessel, objects, lines, runlines, DTMs and point clouds. 

By default, Helmsman’s Display starts with one Map View, docked in the centre of the 

screen. Multiple Map Views can be added using View – New Map View. 

Map Views are normally combined with other views like: 

• Range/Bearing View 

• Data View 

• Vehicle Control 

• Cross Profiles 

 

Figure 23 Stand-alone Map View window 
 
 
The Map View is connected to the View Toolbar. 

 
Figure 24 The View Toolbar. Each button corelates to a number. The numbers will be 

described below 
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1. 3D View - Activates a 3D View 
2. 2D View - Activates a 2D View 
3. Side View - Activates a Side View 
4. Align View North Up - Activates a 3D View 
5. Go to – allows the user to move the target to a specific KP value, time or 2D/3D 

position 
6. Toggle bounding box of selected object – adds a bounding box to the Map View 

outlining the survey area 
7. Toggle EDL – allows the user to change between different light settings based on 

non-realistic shading 
8. Toggle Surface Grid – adds a surface grid to the Map View 
9. Toggle Shore Lines – allows the user to toggle shorelines in the Map View 
10. Toggle World Grid – turns on or off the world grid lines 
11. Select Background Map – allows the user to add a background map from online 

servers. It requires an internet connection. You can read more about this feature 
here. 

12. Screenshot – takes a screenshot of the active Map View 
13. Measure – allows the user to measure distances in the Map View between two 

points or several connected points. 

 

4.3 Graph View 

The plotting of values such as graphs can be beneficial for monitoring specific items over 

time.  

The Graph Views can also present sensor data and statistical data like DOL of the survey 

vessel from the runline during survey operations. It uses live data as well as objects. 

 

The user can combine the Graph View with Custom Live Data for a wide range of options. 

The Graph View can be found under View > New Graph View. 

By right-clicking anywhere inside the Graph View, you can access additional options. 

 

Figure 25 Additional options by right-clicking on the Graph View 
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4.4 Dashboard View 

The Dashboard View is a new type of View designed to optimise the Data View for smaller 

screen or easier docking.  

The available data is displayed with the current value in the middle and features a time 

variation graph behind. 

 

Figure 26 A Dashboard view 

Multiple Dashboard Views can be added. By default, they start docked one on top of the 

other, but they can be undocked and moved according to the user’s needs. 

4.5  Data View 

The Data View is a simplified form of the Dashboard View.  
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4.6 Left/right Indicator 

The Left/Right Indicator can be used to compare the distance or angle from one item to 

another. The list of available options is similar to that of Graph View and Dashboard. 

The most used example is using it as a live distance off line (DOL) indicator for steering the 

vessel on the runline. 

 

Figure 27 Using a DOL Left/Right Indicator (top) to steer the vessel in order to follow a 

runline 
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4.7 Waypoint Profile 

 

The Waypoint Profile view is used for plotting the absolute distance and height in the same 

window and can be found under Views > New Waypoint Profile. The user has the option 

to select the desired two waypoints and the name for the profile.  

 

Figure 28 Options when creating a Waypoint Profile View 

The Z (depth) value is presented on the y-axis while the distance is presented on the x-axis.  

 

Figure 29 Helmsman's Display with a Waypoint Profile docked below the Map View. By 

pressing on the drop-down arrow, the user has additional display options 
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By right-clicking on the Waypoint Profile View, the user has the following options 

 

Figure 30 Options available by right-clicking on the Waypoint Profile View  
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4.8 Range/Bearing View 

The Range/Bearing View is used to display the distance and heading between two objects 

(either a vessel, ROV or a waypoint). The distance can be presented in 2D and 3D. 

 

Figure 31 Helmsman's Display with a Range and Bearing View docked under the Map View 

The user has options for adding and customising items inside one view or add a 

supplementary Range/Bearing View depending to its needs. 
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By right-clicking on the Range/Bearing View, the user has the following options: 

 

Figure 32 Options available by right-clicking on the Range and Bearing View 

4.9 Vehicle Control 

The Vehicle Control view keeps track of all dynamic objects.  

It is a new feature introduced in Helmsman’s Display 4 and basically is an advanced 

version of the Runline Control used in the previous versions of Helmsman’s Display. 

It allows for different objects to be tracked based on different references chosen in the 

Navigation Object column. The Navigation Object cannot be changed when the Status is 

set to Surveying. 

 

Figure 33 Vehicle Control View with customised extra columns 
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The standard columns are the following: 

• Name – it shows the reference objects used for calculation 

• Mode – describes how the object (vehicle) chooses segments in the runline; double 
click on it in order to have the option to change 

• Status – shows if the reference object is using tracking and for what purpose, either 
navigating (yellow), surveying (green) or not used (dash) 

• Navigation Object – The reference for the object 

 

There is a series of supplementary columns that can be added to the Vehicle Control next 

to the standard ones. The user can select them by pressing on the Select Columns button 

on the upper right corner. 

 

Figure 34 Location of the Select Columns button (arrow) and the window it opens 
  



 

 

Page 32 of 59 

4.10 Views 

There is a list of predefined views that can help in customizing the layout for maximum 

efficiency. 

The Views are similar to the ones available in NaviModel. 

 

Figure 35 The available Views under View > Views 
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4.11 Toolbars 

Additional Toolbars can be added from the View > Toolbar menu or by right click on the 

upper right corner in line with or over the EIVA logo. 

 

Figure 36 How to turn Toolbars on and off 
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5 Tools 

The Tools tab offers the user a set of tools to customize the Helmsman’s Display setup. 

A Tool is greyed out if no data is available for that specific tool. 

Some tools are common to NaviModel. 

5.1 Cleaning 

The Helmsman’s Display features histogram-based semi-automatic cleaning functionalities 

for DTMs. They can be accessed using the Tools > Cleaning menu. 

The Histogram cleaning methods rely on an average plane and the distance points have 

from that plane. They are most useful for removing spikes caused by far away points. 

 

Figure 37 Histogram Plane Cleaning; the points within the red boundaries and showing a 

gaussian distribution around the main plane are taken into consideration, while the erratic, 

far-away point is left outside (colored red) and will be cleaned in order to remove the DTM 

spike 
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5.2 DTM 

The DTM tools can be reached using the Tools > DTM menu Except for the Create 

Difference Model… tool, all other DTM visualisation options are accessible also through 

the DTM toolbar. 

 

Figure 38 DTM tools available in Helmsman's Display 4 

The Create Difference Model… option is a useful tool for onsite evaluation of changes 

between consecutive surveys, such as on a dredging or rock dumping project. 

 

5.3 Eventing 

The Eventing tools can be accessed from Tools > Eventing and can be used for new or 

QC-ing online eventing. For further information see the NaviModel manual on Freshdesk. 

5.4 Follow 

The Follow tool is located under Tools > Follow. Additionally, there is a Follow Toolbar with 

similar buttons and options. 

After choosing the object to follow, it basically becomes a collection of tools that allow the 

user to adjust the Map View to follow an object based on: 

• North up – keeps the Map View oriented with North upwards 

• Runline up – Runline will always be pointing towards up in the Map View 

• Gyro up – uses the vessel heading to orientate the Map 
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• CMG up – uses Course Made Good as up in the Map View 

Additionally, the user can set which object should be followed in the Map View, the amount 

of forward looking, the angle of the follow mode and a zone defining the follow mode. 

 

5.5 Lines 

5.5.1 New Digitized Line 

Digitized lines are tridimensional lines. In order to create one, the user can use the Tools > 

New Digitized Line command or use the button from the Create Toolbar or by pressing 

Ctrl+D.  

After naming it and clicking OK, the cursor gets in the design mode and can draw the lines 

with left clicks. When all nodes are added, the user can exit the line design mode by double 

clicking when placing the last node. 

The Digitized Lines can be found in the Project Tree under Digitized Lines. If the user 

clicks on the digitized line in the Project Tree, he can adjust various parameters. 

A node can be moved by dragging with the mouse, or by moving the X,Y or Z arrow. 

 

Figure 39 Moving a line node 
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The start node is displayed with green and the end node with red. The middle nodes are 

coloured white. By double clicking on a node in the middle of the digitized line, a 

supplementary node can be created in its vicinity. 

 

Figure 40 How to add a middle line node 

If the user wishes to continue the line, he must double click on the end or start node and he 

will be able to add a new one. 

 

Figure 41 How to add a new start or end node  
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5.5.2 New Runline 

 

The New Runline tool is located in Tools > Lines > New Runline, as well as in the Create 

Toolbar. 

After adding the name of the New Runline, the user will see an Arc Radius Window where 

he can specify the radius of the arc.  

If the arc points are coloured red, the user is not allowed to place the next point in that 

location because it does not meet the arc setting. A vessel that would have to manoeuvre 

on this runline, would have to steer more than the arc radius parameters and would not be 

able to follow the designed runline. 

 

 
Figure 42 Left: Blue line, the arc radius fits within the curve; right: the bending requirements 

are not OK 

The Runline will be placed in the Project Tree. If the user clicks on the runline in the 

Project Tree, he can adjust various parameters for the runline. 

Runlines can be also added to the project by drag and drop (.rln or .rlx files) and through the 

Import functionality. 

By right click-in on a runline, the user has multiple options, among which the possibility to 

add parallel or perpendicular lines. 
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5.5.3 New Star Runline 

The New Star Runline tool is located in Tools > Lines > New Star Runline. 

It is mostly intended for planning surveys from different directions over a target, such as a 

wreck survey. 

The set of parameters for setting a star runline can be seen in the screen shot below. 

 

Figure 43 Create Star Runline: window with settings and resulting star runline 
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5.5.4  New Waypoint 

The New Waypoint tool is located under Tools > Lines > New Waypoint or by pressing 

Ctrl+W. A waypoint will be created this way at the target location. 

 

 

 
Figure 44 Helmsman’s Display. Upper picture: after using the Add Waypoint tool, the user is 

prompted for a name for the waypoint; down: after naming it, the new waypoint is added at 

the target location 
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5.5.5 New Waypoints 

The New Waypoint tool is located under Tools > Lines > New Waypoints or can be 

accessed by the Add Waypoints button on the Create Toolbar. 

The New Waypoints tool will change the cursor so that the user can set the location of the 

new Waypoint. 

If needed, the X, Y and Z coordinates of the waypoint can be adjusted from the Properties 

Panel, after selecting the waypoint from the Project Tree. 

 

Figure 45 Adding a new Waypoint using the Add Waypoints functionality 
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5.5.6 Vehicle Control 

The Vehicle Control tool can be accessed also from Tools > Lines > Vehicle Control. 

The buttons will allow the user to have the following line related actions: 

1. Start Line 

2. Invert Line 
3. Next Segment 
4. Next Parallel 
5. Reverse Stepping 
6. Stop Runline 
7. Left/Right Indicator 
8. Data View 

 

Figure 46 The buttons on the vehicle Control View, numbers according to the above 

paragraph 
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5.6 Live Data 

The Helmsman’s Display 4 comes with tools that allow the user to customize and adjust 

existing tools to present data relevant for the survey operation. They can be accessed from 

the menu Tools > Live Data and can be seen in the image below. 

 

Figure 47 Live Data Menu 

The following sub-chapters will detail some of the most useful ones. 

5.6.1  Custom Live Data 

This tool allows the user to insert mathematical functions to calculate values that are not 

directly available in Helmsman’s Display 4. 

For example, this tool allows for the transformation between meters to feet by multiplying 

with 3.280839895. 
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Figure 48 Converting depth in meters to depth in feet using Custom Live Data 

5.6.2 Distance between positions 

This feature allows the user to set up a Data View or Dashboard with dx, dy, dz, 2D and 3D 

range and bearing for 2 objects or vehicles. 

After pressing on Tools > Live Data > Distance between positions, a range and bearing 

entry is created in the Project Tree under Live Data. The user has the option in the 

Properties pane to select the two objects. 

 

The user can later display the live data in the way described in chapters 4.4 Dashboard 

View or 4.5 Data View.  
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5.6.3 Distance to DTM  

 

This feature allows for the calculation of the live distance from one object to a DTM. 

The user can click on Tool > Live Data > Distance to DTM and choose the desired object 

and DTM. The newly calculated Live Data will appear in the Project Tree and will be 

available for display using Data View or Dashboard. 

 

Figure 49 Selecting the two items 

 

Figure 50 Displaying the resulting Live Data using a Dashboard; the name and followed 

objects can be changed in the Properties panel (highlighted by the red box) 
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5.6.4 Difference between two values 

The Difference between two values allows for displaying live differences between two 

given values.  

The user can choose a pair of two values after clicking on Tool > Live Data > Difference 

between two values. They will appear as one new entry under Live Data. 

In the example below, there are 3 differences displayed in data View, one for the difference 

in gyro, one for the difference in easting and one for the difference on northing between the 

Vessel and ROV. 

 

Figure 51 Live Data View of E/N differences between the Vessel and the ROV 
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5.6.5 Difference between object and line 

The Difference between object and line allows for displaying live difference values 

between an object (e.g. vessel/ROV) and a digitized line.  

 

Figure 52 Distance from an ROV object (CRP) to a digitized line 
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5.6.6 Distance from object to mouse cursor 

This option shows the distance between the object’s CRP and the position of the mouse 

cursor. If using a DTM, the position where the mouse is touching the DTM is used. 

 

Figure 53 Distance from object's CRP to the mouse cursor on the DTM 
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5.6.7 Depth of Burial 

The Depth of Burial (DOB) tool is used to calculate depth of burial at a specific location. 

The feature is designed for trenching projects, for instance, buried cable lay operations, 

where DOB can be used to monitor the depth the cable is being placed at the tip of the saw 

laying the cable. 

 

Figure 54 A DOB dashboard showing the saw above the DTM 
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5.6.8 KP for object 

This feature is used to show the live KP value along a runline for an object. 

By choosing Tools > Live Data > Kp for object, a Kp for object entry will appear under 

Live Data. By clicking on it on the Project Tree and from the Properties Panel, the user 

can select the Host, Runline and Name for the Live Data. This ca be later displayed as a 

Data View or Dashboard. 

 

Figure 55 Kp for object displayed as Data View; the name, host and runline can be selected 

from the Properties Panel (red box) 
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5.6.9 Log Live Data 

This feature allows the user to log live data as a file on the local PC or to send it through 

UDP or TCP. 

It can be set up by going to Tools > Live Data > Log Live Data. This will create a 

LiveDataLogger entry under Live Data in the Project Tree. By right clicking on it, the user 

has the option to select what data to log (points 1-3 on the image below). 

The user also has to set up the Logging parameters (interval, file path or UDP/TCP port, 

time in first column and resolution). 

 

Figure 56 Settings for setting up a Live Data Logging to file 

 Using the above settings, the resulting file looks like this: 

2020.11.18 14.15.41.080,1.136 

2020.11.18 14.15.42.084,1.136 

2020.11.18 14.15.43.093,1.137 
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5.7 Live Point Clouds 

The Live Point Clouds tool is useful to bring live sensor data in as point cloud data. It could 

be used for e.g. monitoring fluid seepage along a pipeline, or to keep track of the position of 

a vehicle.  

It can be used to display multiple live data at a time. 

 

Figure 57 Live Data Visualiser window 
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Figure 58 Live Point Cloud for the ROV position 

5.8 Maps 

This button provides the options for Maps.  

 

Figure 59 Options for Maps 

• Select Background Map – will open a window where the user can choose a Web 

Map Server from where to take map tiles 

• Toggle surface grid – will add or remove the easting and northing grid on the 

display 

• 2D View – will take the view as seen from above and make everything a horizontal 

2D 
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• Toggle Shore Lines – will add or remove a digitization of the world shore lines 

• Toggle World Grid - will add or remove parallels and meridians 

• Align view North Up – will rotate the Map View with North up 

• Go to… - allows the user to jump at a specified KP, time or position 

• Toggle bounding box of selected object – add or remove a bounding box around 

the object which is selected 

 

Figure 60 Bounding box around selected object 

5.8.1 Adding a user Web Map Server 

The user has the option to add custom web map servers from where he can add 

Background Maps. 

To do that, the user should right-click on the Maps entry in the Project Tree and choose 

“Add new map”. 

 

Figure 61 Where to find Add new Map 
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Fill the name under which you wish to have the new map and the WMS URL. Some 

additional options are available. 

 

Figure 62 The Set Map Server window 
 
Following this, when selecting Background Maps, the new map should be available. 
 

 
Figure 63 The new WMS can be found in the list of Background Maps 
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5.9 Measurements 

This set of tools provide profile and measurement tools for the information and data in 

Helmsman’s Display. 

 

• Toggle profile on/off – will open a Quick Profile 

• Toggle axis profile on/off – will open an Axis Profile – a set of 2 profiles along the 

X and Y axis 

• Measure – will open the Measure tool that can provide distances and angles 

• New TIN Along Line – will open the window for creating a TIN model along a 

specified line 
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5.10 Misc 

The Miscellaneous category comprises the following: 

 

Figure 64 The Misc section of the Tools Menu 
 

• Virtual Buoy Manager – adds an entry in the Project Tree for Virtual Buoys 

• Node Sorter – opens the Node Sorter 

• Live Folder – opens a window where the user can set up a Live Folder 

• Side Scan Sonar Classifier Tool – opens the classification tool for SSS data 

 

5.11 Patch Test 

The Patch Test function is described in a separate manual and is the same tool as in 

NaviModel:  

https://eiva.freshdesk.com/support/solutions/articles/43000548378-patch-test-calibration-

with-navimodel 

5.12 Point Clouds 

The Point Cloud tools are the same as in NaviModel.  

Please refer to NaviModel’s help and manuals for a detailed description. 

  

https://eiva.freshdesk.com/support/solutions/articles/43000548378-patch-test-calibration-with-navimodel
https://eiva.freshdesk.com/support/solutions/articles/43000548378-patch-test-calibration-with-navimodel
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5.13 Video Recording 

The Video Recording tab provides tools for recording the Helmsman’s Display screen. 

 

Figure 65 The tools from the Video Recording tab 

• Record Video – will open a window that will allow for recording of the Helmsman’s 

Display whole window or just the Map View 

• Screenshot – will take a screenshot of the display 

• Add camera key frame – will add a keyframe for the camera 

• Fly Mode – will provide options for the fly mode, such as to follow a runline or 

digitized line for creating a Fly Video 
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6 Version descriptions 

Version Date Author Description 

4.2.3 30/09/20 VLA Initial draft 

4.5.4 20/08/21 VLA Updated draft to new interface 

    

    

 


